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Chapter 1 Description 

 

Description 

  
Explanation of terms OPC stands for “OLE for Process Control”. It is a standardized data communication 

interface based on the Microsoft Windows OLE/DCOM technology. 
 
The AO-OPC OPC server operates with all OPC clients (data access). 
 
Further information about OPC is available on the Internet at 
http://www.opcfoundation.org. 

  
Network structure 

 

  
AO-OPC OPC Server The AO-OPC OPC server is a standard software interface to the Advance Optima 

AO2000 Series gas analyzers (all software versions).  
 
The OPC server can also communicate with any SCADA, DCS or PLC system which 
has an OPC client (data access). 
 
The AO-OPC OPC server runs on the computer as a service, i.e. invisible in the 
background. 

  
Connection with 
several gas analyzers 

It is possible to establish connections to several gas analyzers with different software 
versions from one OPC application at the same time.  
 
Data of the individual gas analyzers can be displayed in the diagnostics window of the 
AO-OPC remote control. 

  
AO-OPC 
remote control 

AO-OPC remote control is used to configure a local OPC server (running on the same 
computer) as well as to configure an OPC server running on another computer 
connected to the local network. 

 
Continued on next page 
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Description, continued 

  
Read access The OPC server makes the most important data from the gas analyzer available for 

further processing. Details can be found under data tag descriptions (see page 29). 
The data that can be read from the gas analyzers include the following: 
• Analyzer data, connection status and general data, 
• Diagnostic/status information such as failure, maintenance request, maintenance 

mode, 
• Measured values, 
• Values of the analog inputs and outputs, 
• Status of the digital inputs and outputs, 
• Auxiliary variables such as detector temperature or flow rate, 
• Values for zero drift and span drift. 

  
Write access In addition to read-only access via the OPC server, write access to the gas analyzer’s 

control inputs is also possible. In conjunction with a function block configuration many 
different functions can thus be executed using the Ethernet interface, e.g.: 
• Starting automatic calibration 
• Switching measuring ranges. 

  
Redundant 
Ethernet lines 

A redundant link between the gas analyzer and the AO-OPC OPC server can be 
created by configuring a second Ethernet line (see figure “Network Structure” on 
page 4). Both Ethernet lines are monitored continuously. If one line fails, the system 
switches over to the redundant line. 
 
Note: In this case, a second network card must be built-in in the gas analyzer as well 
as in the computer on which the OPC server is installed. 

  
Recommendation for 
the installation 

The OPC server and OPC client(s) may in principle be installed on separate 
computers. However, the DCOM method used is more difficult to configure and more 
sensitive to faults on the connection than is the COM method which is used when the 
OPC server and OPC client(s) are installed on the same computer. We recommend in 
general that you install the OPC server and OPC client(s) on the same computer. 
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Chapter 2 Installation 

 

Installing and uninstalling AO-OPC 

  
System requirements • Operating system:  

Windows 7 (32-bit), Windows 7 (64-bit)  
Windows 8.1 (32-bit), Windows 8.1 (64-bit)  
Windows 10 (32-bit), Windows 10 (64-bit)  
Windows Server 2008 R2  
Windows Server 2012 R2  
Windows Server 2016 

 
• Network card (and 2nd network card for redundancy operation) configured under 

Windows with TCP/IP 
 
• Administrator rights on the computer are required for installation. 

  

 
Before installing AO-OPC you must uninstall an already existing older version of AO-
OPC. 

  
Installing AO-OPC Step Action 

1 Insert CD-ROM containing the AO-OPC program in the drive. 
2 Run “ao_opc_x_y_z.exe”. 

“x_y_z” corresponds to the current program version. 
3 Follow the instructions in the installation program. 

 
The installation program will propose installing AO-OPC in the 
“Analyze IT” folder; this can simply be accepted. All the Analyze IT 
software tools are installed in this folder by default. 

  
Uninstalling AO-OPC Step Action 

1 Shut down service (see page 9). 
2 Deregister by AO-OPC remote control (see page 8). 

 
If not, several entries will remain in the Windows Registry. 

3 Uninstall the AO-OPC software. 

 
To do this, use the icon “Software” in the control panel. 
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Chapter 3 Configuration 

 

First steps 

  
Remote control All steps required for configuration can be made by "AO-OPC Remote Control". The 

remote control is used to configure a local OPC server (running on the same 
computer) as well as to configure an OPC server running on another computer in the 
local network. 

  
Starting 
remote control 

To run the remote control call "AO-OPC Remote Control" from "Start → Programs → 
Analyze IT → AO-OPC". 
  

 

 

  
Password In order to change the settings, you have to log in with the appropriate password. The 

corresponding dialog is opened via the menu "Options → Access password". 

  
Password levels Password Access Rights 

325465 User has all rights. 
081500 User can configure connections. 
No or faulty entry User has the right to connect to one gas analyzer and view 

the values 
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Settings 

  
Settings The settings can only be made locally on the computer on which the program "AO-

OPC Remote Control" is called. Clicking on the menu "Options → Settings" opens 
the corresponding dialog. 

Only users with administrator rights can access the menu. 

  
Registration 

 
  

Setting the 
registration 

• “The AO-OPC server is to run as service.”  
If the server is running, it is shut down on request. The registration of the server will 
be done as “Service”. If necessary, the server is restarted on request. 

• Start type “Manual”: The service is not automatically started upon starting the 
computer, but has to be started via “Settings → Control Panel → Administrative 
Tools → Services → OptimaOPCService”. An OPC client connecting with the 
OPC server can also start the server, if the DCOM-settings permit this. 

• Start type “Automatic”: When the computer is started, the service is automatically 
started. In this case, there is no need for a user to be logged in. 

• “The AO-OPC server is to be deregistered.”  
If the server is running, it is shut down on request.  

 

The server is deregistered. A deregistered OPC server can no longer be started by 
an OPC client. 

  

 
• While you are setting the registration, no Services Control Panel should be opened, 

because otherwise the values shown in this Control Panel and in the AO-OPC 
dialog Registration might be faulty. 

• Any change in the registration of the OPC server will cause a reset of the DCOM 
settings for the application Optima OPC Service. As a result, you possibly need a 
new permission for an access by a remote OPC client. 

 
Continued on next page 
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Settings, continued 

  
Permissions for 
remote control 

 
  

Setting the 
permissions for 
remote control 

• Remote control of the OPC server is permitted from all PCs of the local network. 

• The OPC server may only be remote-controlled from the PC on which it has been 
installed. 

• Remote control of the AO-OPC server is not allowed at all. 

• Port: Indicates the port number used for remote control by the OPC server. 

  
Starting the 
OPC Server 

Having confirmed the settings with "Ok", you will see the following request: 

 

"Yes" The OPC server is started at once. 

"No" The OPC server can be started later. 

  
Stopping the 
OPC Server 

Proceed as follows to stop the OPC server: 

Open "Settings → Control Panel → Administrative Tools → Services", select "Optima 
OPC Service" and click on the "Stop" command in the popup menu. 
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Configuring connections 

  
Configuring 
connections 

Connections can be configured in online or offline mode. If the connection to a server 
is made via "Service Remote Control", you are in online mode. In this case the 
connection configurations affect the server to which you are connected. In offline 
mode, the configurations are made for the computer on which the remote control is 
running. 
 
The menu options "File → Connect…" and "File → Remove Connection…" are only 
available in online mode. 

  
Add 
AO2000 connection 

 
  

 The dialog can be opened via the menu "File → Connect…" (only in online mode).  
A unique AO2000-Reference-Number, a Hostname and an Update Rate must be 
entered. The Backup Hostname is optional. 

  
Remove 
AO2000 connection 

 
  

 With "File → Remove Connection…" you can remove an existing connection (only in 
online mode). Choose the AO2000 Reference name of the connection which is to be 
removed. The other dialog fields show details of the currently selected reference 
name. The connection is deleted by closing the window with "Ok". 

 
Continued on next page 
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Configuring connections, continued 

  
AO2000 
connection manager 

 
  

 Click on "File → Connection Manager" to open the above window which makes it 
possible to manage all connections at a glance. Using the drag&drop function you can 
move connections from the "Actual Configuration" to the "New Configuration" to edit 
them comfortably there. 

 
 By clicking the right mouse key in the list "New Configuration" a pop-up menu with 

the following menu options will appear: 

"Add" Adds a new entry to the configuration. 

"Edit" Edits the configuration of the currently selected entry. 

"Delete" Deletes the currently selected entry. 
 
 Closing the window with "Ok" saves the new configuration. In offline mode this is done 

by overwriting the INI file of the OPC server, in online mode by remote control of the 
corresponding OPC server. 
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Configuring remote control 

  
Remote control Using the remote control you can connect to any OPC server in the network that has 

been enabled for remote control. 
 
Remote control makes it possible to view the tags of the server and – with the 
appropriate password – to configure the connections. 

  
Service remote control 

 
  

 Click the menu option "Service → Remote control…" to open the dialog. 
 
• Control service on a network computer  

If this option is enabled and the dialog is exited with "Ok", the remote control tries to 
connect to the OPC server running on the computer of which the IP address or 
server name has been entered.  
If this option is disabled and the dialog is exited by pressing "Ok", the remote 
control tries to connect to a locally installed OPC server. 

• IP address 
IP address of the computer on which the OPC server to be connected to is running. 

• Server name 
Server name of the computer on which the OPC server to be connected to is 
running. 

• Port 
Port number of the port to which the socket is connected. Needs to be the same 
as selected on the computer running the OPC-Server at "Options → Settings… → 
Permissions for remote control". 

  
End remote control Select the menu option "Service → End Remote Control". The remote control is 

stopped and the contents removed from the window. 
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DCOM configuration 

  
Modifying the 
DCOM settings of 
Windows 

The DCOM settings of Windows must be customized, so that an OPC client can 
connect to the AO-OPC server.  

The following description is based on the Windows 7 default configuration with 
Service Pack 1 installed. 

You require administrator rights to execute the following actions. 

  
1 Click the Windows Start button and type “dcomcnfg” in the Search line. “dcomcnfg” 

should appear in the top part of the box as a search result.  

Click “dcomcnfg.exe” to start the program. 

 
 

Continued on next page 
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DCOM configuration, continued 

  
 If you have sufficient rights, the following box will open. 

 

  
2 Double-click to expand the “Component Services” and the “Computers” folders. 

(Already expanded in the above figure) Right-click “My Computer” and then click 
“Properties”. 

 
Continued on next page 
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DCOM configuration, continued 

  
3 Click to select the “Default Properties” tab. 

 

 

  
4 Check your display against the settings and make changes to your settings if 

required. 
 

Continued on next page 



 

16 AO-OPC Software version 2.1 User’s manual 42/24-23 EN Rev. 4 

DCOM configuration, continued 

  
5 Click to select the “COM Security” tab. 

 

 

  
6 Add the two system objects “SYSTEM” and “INTERACTIVE” (unless already added) in 

“Access Permissions → Edit Default…” and in “Launch and Activation Permissions → 
Edit Default…”. 

 
Continued on next page 
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DCOM configuration, continued 

  
7 Add the objects “SYSTEM” and “INTERACTIVE” with local Launch, Access and 

Activation Permissions set. If you plan to launch or poll the AO OPC server from a 
remote OPC client, also enable the remote permissions (Remote Launch, Remote 
Activation and Remote Access) for the above objects. 

 

  

  
8 To add an object, click “Add…” and enter the respective object name in the following 

box. 

  
9 Exit the selection dialogs with “OK”. If a warning box appears, confirm it with “OK”. 

  
10 If you plan to run the AO-OPC server, an OPC client and the AO2000 OPC remote 

control on the same computer, you do not need to make any further settings. 
However, please read the section “Completing the Configuration and Important 
Information” on page 28. 

If you only wish to use the AO2000 OPC Remote Control from a remote computer, 
then you also have to enable the port for remote control (normally 9531) in the 
Windows Firewall. This is carried out in the same way as in the subsequent 
description for the DCOM port with a remote OPC client. Name: OPC Remote 
Control / port number: 9531 / TCP.  

If you plan to launch or poll the AO OPC server from a remote OPC client, you do not 
need to enable the port, since the complete AO-OPC server application then has to 
be enabled in the Windows Firewall. (see below) 

 
Continued on next page 
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DCOM configuration, continued 

  
11 If you plan to launch or poll the AO OPC server from a remote OPC client, you have to 

make some further settings in the Component Services and possibly in the Windows 
Firewall. Furthermore, all the settings have to be implemented on the AO-OPC server 
computer and the OPC client computer. (Also the previous settings for “COM Security / 
Edit Default…”) 

The “Edit Limits…” buttons can be found under the “COM Security” tab (“dcomcnfg → 
Component Services → Computers → My Computer → Properties”, see above) under 
“Access Permissions” and “Launch and Activation Permissions”. The subsequent 
remote permissions are added there: 

 On the OPC server and  
the OPC client computer:  
ANONYMOUS LOGON:  
Allow Remote Access. 

Only on the OPC server computer:  
 
Everyone: Allow Remote Launch and 
Allow Remote Activation 

 

  

  
12 The other permissions do not have to be set under “Default Security” of 

“My Computer”, but can be specifically set for the “Optima OPC Service” under 
“DCOM Config”.  

Settings for the “OPCEnum” service also have to be made. 

  
13 All users who wish to access the AO-OPC server from a remote OPC client should be 

known to the Windows user management on the OPC server computer. As an 
alternative, you can also use the object “Everyone” for the permissions; this gives 
access permissions to all known users. “Known users” means having a user with the 
same user name and matching passwords on the OPC server computer and on the 
OPC client computer. Empty passwords are not allowed for users that should get 
access to the OPC server. The use of “Everyone” is generally advised against for 
security reasons. Define users and groups of the users who should have access to 
the OPC server in the Windows user management. 

 
Continued on next page 
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DCOM configuration, continued 

  
14 Choose the item “Optima OPC Service” from the “Component Services” window 

under “Computers → My Computer → DCOM Config”. 

 

  
15 Right-click to open the “Properties” dialog. 

 

 
 

Continued on next page 
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DCOM configuration, continued 

  
16 Set “Customize” in “Launch and Activation Permissions” and “Access Permissions” 

and click “Edit”. You obtain the security dialogs in the same way as for the “Default 
Security” dialogs above. 

 

  

  
17 Click “Add” and select the users and/or groups who should have access from a 

remote OPC client in the following dialog. 

You can also select “Everyone” here (not recommended, see above) or the object 
“NETWORK”. The latter also gives all known users access permissions, but is 
restricted to users from remote computers. 

Ensure that the remote permissions (Remote Launch, Remote Activation and Remote 
Access) are enabled for the selected objects. 

  
18 You must also carry out the same actions for the “OPCEnum” service. 

This action must also be carried out for the “OPCEnum” service on the computer, on 
which the OPC client is running. These settings are also to be made for the OPC 
client if the OPC client is also a service (i.e. not a normal application). 

  
19 Exit the “Component Services” dialog. 

 
Continued on next page 
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DCOM configuration, continued 

  
Configuration of the 
Windows Firewall 

The Windows Firewall off is exception-based, i.e. you have to except the requisite 
ports or applications from the blockade. 

If you disable the firewall completely, you do not need to make any further settings. 
Otherwise proceed as described below. 

  
20 Open the “Windows Firewall with Advanced Security” window via “Control Panel → 

System and Security → Administrative Tools”. 

The firewall is normally active. 

 
 

Continued on next page 
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DCOM configuration, continued 

  
21 Click “Inbound Rules” in the left-hand pane, then “New Rule…” in the right-hand 

pane. 

 
 

Select “Program” and click “Next”. 
 

Continued on next page 
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DCOM configuration, continued 

  
22 

 

 You can enter the path to the OPC server via “Browse”. The default path is 
“C:\Program Files\Analyze IT\AO-OPC\OptimaOPC.exe” or “C:\Program Files 
(x86)\Analyze IT\AO-OPC\OptimaOPC.exe” in the 64 bit version of Windows 7.  

Here you have to select the program file of the OPC client on the OPC client 
computer. Click “Next”. 

 
Continued on next page 
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DCOM configuration, continued 

  
23 

 

 Select “Allow the connection” and click “Next”. 

  
24 

 

 Select the profiles for which the rule should apply and click “Next”. 

Continued on next page 



 

42/24-23 EN Rev. 4 AO-OPC Software version 2.1 User’s manual 25 

DCOM configuration, continued 

  
25 

 

 Finally, give the rule a name and provide it with a comment if required. Complete the 
creation of the rule with “Finish”. 

  
26 Repeat these steps for the “OPCEnum” service. The program file is normally installed 

under “C:\Windows\System32\OpcEnum.exe”.  

The file is normally located under “C:\Windows\SysWOW64\OpcEnum.exe” in the 64 
bit version of Windows 7. 

 
Continued on next page 
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DCOM configuration, continued 

  
27 Furthermore, you have to enable TCP port 135 for the DCOM communication. 

This setting must be made on the AO-OPC server computer and the OPC client 
computer.  

The settings are made in the same way as for a program share, therefore only the 
dialogs which differ from the share dialogs for the OPC server are shown in the 
following. 

Select rule type “Port” under “New Rule…”. 

 

 
 

Continued on next page 
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DCOM configuration, continued 

  
 

 

 Enter port “135” under “Specific local ports:”. 

 
Continued on next page 
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DCOM configuration, continued 

  
Completing the 
configuration and 
important information 

Re-start the computer. 

Any re-registration of the AO-OPC server causes the DCOM settings for the “Optima 
OPC Service” application to be reset. This could mean that the access of a remote 
OPC client first of all has to be enabled again. 

If the AO-OPC server is launched via the OPC client, it takes quite a while before the 
list of the tags is provided by the AO-OPC server. It is therefore possible that certain 
tags are not found after start-up. These tags are displayed after a while. 

  
Trouble-shooting:  
No connection to 
OPC client 

If the OPC server is automatically launched at the system start and a connection to a 
OPC client cannot be subsequently started (although all the DCOM and Firewall 
settings were carried out in accordance with the above description), first of all try to 
re-start the OPC server and the OPCEnum service via the “Control Panel → System 
and Security → Administrative Tools → Services”. If it starts, there may be a problem 
with the network configuration. If a fixed IP address is allocated to a network interface 
and no default gateway has been entered for this interface, it can prevent the OPC 
server from starting correctly. In this case, check the Windows Protocol “System” in 
the Event Viewer under “Control Panel → System and Security → Administrative 
Tools → Event Viewer” for warnings or errors with the source “Distributed COM” or 
“DNS Client Events”. 
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Chapter 4 Data tags 

 

Preface 

  
Elements of tags Tags are composed fundamentally of several names separated by dots. Certain 

names are followed by an index in the form of a number in order that objects with 
more than one instance can be given a unique name. 

  
Example “Optima1.Analyzer2.MainDetectorCount” designates the number of primary 

components (MainDetectorCount) of the second analyzer (Analyzer2) of the first gas 
analyzer (Optima1). 

  
Indexes In the following tag tables the indexes are replaced with wildcards (*). The indexes are 

counted from 1 up to the maximum number for each object. 
 
With the tag “Optima*.IO_Card” there is also the index IO_Card0 which addresses the 
gas analyzer’s I/Os located on the Syscon board. 

  
Legend Format VT_BOOL Bool 

VT_BSTR OLE automation string 

VT_I4 4-byte signed integer 

VT_R8 8-byte real number 

Note M Tags required for displaying the measurement functions of 
the gas analyzer (basic information) 

D Tags required for displaying further functions of the gas 
analyzer 
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Connection status 

  
Tag Description Format Note 

Optima*.IsConnected1 Connection status to the primary IP address VT_BOOL M 
Optima*.IsConnected2 Connection status to the secondary IP address VT_BOOL M 

  

General data 

  
Tag Description Format Note 

Optima reference number 
Optima*.AnalyzerCount Number of analyzers VT_I4 D 
Optima*.IO_CardCount Number of I/O cards VT_I4 D 
Optima*.IO_ModuleCount Number of bus I/Os VT_I4 D 
Optima*.NoErrors Number of global device errors VT_I4 M 
Optima*.NoMaintMode Maintenance mode if ≠ 0 VT_I4 M 
Optima*.NoMaintReq Maintenance request if ≠ 0 VT_I4 M 
Optima*.SoftwareVersion Software version of gas analyzer VT_BSTR D 
Optima*.ComponentCount Number of components VT_I4 D 
Optima*.AI_Count Number of analog inputs VT_I4 D 
Optima*.AO_Count Number of analog outputs VT_I4 D 
Optima*.DI_Count Number of digital inputs VT_I4 D 
Optima*.DO_Count Number of digital outputs VT_I4 D 
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Analyzer data 

  
Tag Description Format Note 

Optima reference number and analyzer number 
Optima*.Analyzer*.ModuleName Module name VT_BSTR M 
Optima*.Analyzer*.UserText User text VT_BSTR M 
Optima*.Analyzer*.SerialNo Serial number VT_BSTR D 
Optima*.Analyzer*. 
MainDetectorCount 

Number of main detectors VT_I4 D 

Optima*.Analyzer*. 
AuxDetectorCount 

Number of auxiliary detectors VT_I4 D 

Optima reference number, analyzer number and main detector number 
Optima*.Analyzer*.MainDetector*. 
CompCount 

Number of components of main detector VT_I4 D 

Optima*.Analyzer*.MainDetector*. 
ActiveComponent 

Index of the active component of the main detector VT_I4 D 

Optima reference number, analyzer number and main detector number 
Optima*.Analyzer*.MainDetector*. 
AmplOver 

Threshold at which the amplification drift exceeds 
the permissible range. 

VT_R8 D 

Optima*.Analyzer*.MainDetector*. 
OffsetOver 

Threshold at which the offset drift exceeds the 
permissible range. 

VT_R8 D 

Optima*.Analyzer*.MainDetector*. 
DeltaAmpl 

Threshold at which the amplification drift between 
two automatic calibrations exceeds the permissible 
range. 

VT_R8 D 

Optima*.Analyzer*.MainDetector*. 
DeltaOffset 

Threshold at which the offset drift between two 
automatic calibrations exceeds the permissible 
range. 

VT_R8 D 

Optima reference number, analyzer number, main detector number and component number 
Optima*.Analyzer*.MainDetector*. 
Component*.CompName 

Component name VT_BSTR M 

Optima*.Analyzer*.MainDetector*. 
Component*.UnitName 

Unit name VT_BSTR M 

Optima*.Analyzer*.MainDetector*. 
Component*.MeasVal 

Measured value VT_R8 M 

Optima*.Analyzer*.MainDetector*. 
Component*.Status 

Status VT_I4 D 

Optima*.Analyzer*.MainDetector*. 
Component*.MeasRangeCount 

Measuring range count VT_I4 D 

Optima*.Analyzer*.MainDetector*. 
Component*.RangeLow 

Measuring range start VT_R8 D 

Optima*.Analyzer*.MainDetector*. 
Component*.RangeHigh 

Measuring range end VT_R8 D 

 
Continued on next page 
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Analyzer data, continued 

  
Tag Description Format Note 

Optima reference number, analyzer number, main detector number, component number and measuring 
range number 
Optima*.Analyzer*.MainDetector*. 
Component*.MeasIdx*.AmplDrift 

Cumulative amplification drift since the base 
calibration 

VT_R8 D 

Optima*.Analyzer*.MainDetector*. 
Component*.MeasIdx*.OffsetDrift 

Cumulative offset drift since the base calibration VT_R8 D 

Optima*.Analyzer*.MainDetector*. 
Component*.MeasIdx*.DeltaAmpl 
Drift 

Amplification drift between two autocalibrations VT_R8 D 

Optima*.Analyzer*.MainDetector*. 
Component*.MeasIdx*.DeltaOffsetDr
ift 

Offset drift between two autocalibrations VT_R8 D 

Optima reference number, analyzer number and auxiliary detector number 
Optima*.Analyzer*.AuxDetector*. 
CompCount 

Number of components of auxiliary detector VT_I4 D 

Optima*.Analyzer*.AuxDetector*. 
ActiveComponent 

Index of the active component of the auxiliary 
detector 

VT_I4 D 

Optima reference number, analyzer number, auxiliary detector number and component number 
Optima*.Analyzer*.AuxDetector*. 
Component*.CompName 

Component names VT_BSTR M 

Optima*.Analyzer*.AuxDetector*. 
Component*.UnitName 

Unit name VT_BSTR M 

Optima*.Analyzer*.AuxDetector*. 
Component*.MeasVal 

Measured value VT_R8 M 

Optima*.Analyzer*.AuxDetector*. 
Component*.Status 

Status VT_I4 D 

Optima*.Analyzer*.AuxDetector*. 
Component*.RangeLow 

Measuring range start VT_R8 D 

Optima*.Analyzer*.AuxDetector*. 
Component*.RangeHigh 

Measuring range end VT_R8 D 
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I/O data 

  
Tag Description Format Note 

Optima reference number and I/O card number 
Optima*.IO_Card*.DeviceName I/O device name VT_BSTR M 
Optima*.IO_Card*.UserText User text VT_BSTR M 
Optima*.IO_Card*.SerialNo Serial number VT_BSTR D 
Optima*.IO_Card*.SlotNo Slot number VT_I4 D 
Optima*.IO_Card*.AI_Count Number of analog inputs VT_I4 D 
Optima*.IO_Card*.AO_Count Number of analog outputs VT_I4 D 
Optima*.IO_Card*.DI_Count Number of digital inputs VT_I4 D 
Optima*.IO_Card*.DO_Count Number of digital outputs VT_I4 D 
Optima reference number, I/O card number and analog input number 
Optima*.IO_Card*.AI*.Name Name VT_BSTR M 
Optima*.IO_Card*.AI*.Unit Unit VT_BSTR M 
Optima*.IO_Card*.AI*.Val Value VT_R8 M 
Optima*.IO_Card*.AI*.Status Status VT_I4 D 
Optima*.IO_Card*.AI*.HardwareLink Channel address of the component VT_I4 D 
Optima*.IO_Card*.AI*.RangeLow Measuring range start VT_R8 D 
Optima*.IO_Card*.AI*.RangeHigh Measuring range end VT_R8 D 
Optima reference number, I/O card number and analog output number 
Optima*.IO_Card*.AO*.Name Name VT_BSTR M 
Optima*.IO_Card*.AO*.Unit Unit VT_BSTR M 
Optima*.IO_Card*.AO*.Val Value VT_R8 M 
Optima*.IO_Card*.AO*.Status Status VT_I4 D 
Optima*.IO_Card*.AO*.HardwareLink Channel address of the component VT_I4 D 
Optima*.IO_Card*.AO*.RangeLow Measuring range start VT_R8 D 
Optima*.IO_Card*.AO*.RangeHigh Measuring range end VT_R8 D 
Optima reference number, I/O card number and digital input number 
Optima*.IO_Card*.DI*.Name Name VT_BSTR M 
Optima*.IO_Card*.DI*.Val Value VT_I4 M 
Optima*.IO_Card*.DI*.Invert Invert value of the function block VT_I4 D 
Optima*.IO_Card*.DI*.Status Status VT_I4 D 
Optima*.IO_Card*.DI*.HardwareLink Channel address of the component VT_I4 D 
Optima reference number, I/O card number and digital output number 
Optima*.IO_Card*.DO*.Name Name VT_BSTR M 
Optima*.IO_Card*.DO*.Val Value VT_I4 M 
Optima*.IO_Card*.DO*.Invert Invert value of the function block VT_I4 D 
Optima*.IO_Card*.DO*.Status Status VT_I4 D 
Optima*.IO_Card*.DO*.HardwareLink Channel address of the component VT_I4 D 
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Bus I/O data 

  
Tag Description Format Note 

Optima reference number and bus I/O number 
Optima*.BusIO*.AI_Count Number of analog inputs VT_I4 D 
Optima*.BusIO*.AO_Count Number of analog outputs VT_I4 D 
Optima*.BusIO*.DI_Count Number of digital inputs VT_I4 D 
Optima*.BusIO*.DO_Count Number of digital outputs VT_I4 D 
Optima reference number, bus I/O number and analog input number 
Optima*.BusIO*.AI*.Name Name VT_BSTR M 
Optima*.BusIO*.AI*.Val Value VT_R8 M 1) 
Optima*.BusIO*.AI*.Status Status VT_I4 D 
Optima*.BusIO*.AI*.RangeLow Measuring range start VT_R8 D 
Optima*.BusIO*.AI*.RangeHigh Measuring range end VT_R8 D 
Optima reference number, bus I/O number and analog output number 
Optima*.BusIO*.AO*.Name Name VT_BSTR M 
Optima*.BusIO*.AO*.Val Value VT_R8 M 
Optima*.BusIO*.AO*.Status Status VT_I4 D 
Optima*.BusIO*.AO*.RangeLow Measuring range start VT_R8 D 
Optima*.BusIO*.AO*.RangeHigh Measuring range end VT_R8 D 
Optima reference number, bus I/O number and digital input number 
Optima*.BusIO*.DI*.Name Name VT_BSTR M 
Optima*.BusIO*.DI*.Val Value VT_I4 M 1) 
Optima*.BusIO*.DI*.Invert Invert value of the function block VT_I4 D 
Optima*.BusIO*.DI*.Status Status VT_I4 D 
Optima reference number, bus I/O number and digital output number 
Optima*.BusIO*.DO*.Name Name VT_BSTR M 
Optima*.BusIO*.DO*.Val Value VT_I4 M 
Optima*.BusIO*.DO*.Invert Invert value of the function block VT_I4 D 
Optima*.BusIO*.DO*.Status Status VT_I4 D 

 1) writable 

  



 

42/24-23 EN Rev. 4 AO-OPC Software version 2.1 User’s manual 35 

Export tags to a CSV file 

  
Export of existing tags It is possible to export the existing tags of a connection to a CSV file using  

"AO-OPC Remote Control". The user can save several values in the CSV file in 
addition to the data tag names which are always stored. 

  
Tag export settings In AO-OPC Remote Control, use the menu command "Options – Tag Export Settings" 

to open the dialog for selecting the parameters to be exported. Further parameters 
can be selected here in addition to the OPC tags which are generally exported: Value, 
Time stamp, Quality and Description. 
  

 

 

  
Export tags In AO-OPC Remote Control, use the menu command "File – Export Tags" to open the 

dialog for entering a CSV file name. All tags with their additional parameters which are 
also currently displayed in the list view are exported to this file by selecting "OK". The 
individual values of a line are each separated by a tab stop. 
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